PDF-XChange Viewer puffer túlcsordulásos sérülékenység

CH azonosító

CH-8304

Angol cím

PDF-XChange Viewer JPEG Stream Processing Buffer Overflow Vulnerability

Felfedezés dátuma

2013.01.21.

Súlyosság

Magas

Érintett rendszerek

PDF-XChange Viewer
Tracker Software Products

Érintett verziók

PDF-XChange Viewer 2.x

Összefoglaló

A PDF-XChange Viewer egy sérülékenységét jelentették, amit kihasználva a támadók feltörhetik a felhasználó rendszerét.

Leírás

A sérülékenységet egy JPEG adatfolyam feldolgozása közben fellépő hiba okozza, amelyet kihasználva halom alapú puffer túlcsordulást lehet előidézni egy speciálisan összeállított JPEG képet tartalmazó PDF állománnyal.

A sérülékenység sikeres kihasználása tetszőleges kód végrehajtását teszi lehetővé, ha a felhasználó megnyit egy káros tartalmú PDF dokumentumot.

A sérülékenységet a 2.5 Build 207.0 verzióban jelentették, de korábbi kiadások és érintettek lehetnek.

Megoldás

Frissítsen a legújabb verzióra