PEAR nem biztonsági ideiglenes telepítő fájlok sérülékenysége

CH azonosító

CH-4467

Angol cím

PEAR Installer Insecure Temporary Files Security Issue

Felfedezés dátuma

2011.02.28.

Súlyosság

Alacsony

Érintett rendszerek

PEAR
PHP Group

Érintett verziók

PEAR 1.x

Összefoglaló

A PEAR olyan sérülékenységét jelentették, amelyet rosszindulatú helyi felhasználók kihasználva emelt szintű jogosultságokat szerezhetnek.

Leírás

A sérülékenységet a PEAR telepítő hibája okozza, amely az ideiglenes fájlokat nem biztonságos módon hozza létre, ezt kihasználva például tetszőleges fájlok írhatóak felül egy symlink támadással.

A sérülékenységet az 1.9.1 verzióban jelentették. Korábbi verziók is érintettek lehetnek.

Megoldás

Frissítsen a legújabb verzióra

Hivatkozások

SECUNIA 43533
CVE-2011-1072 - NVD CVE-2011-1072
Gyártói referencia: pear.php.net
Gyártói referencia: pear.php.net
Egyéb referencia: bugs.debian.org