Perl Digest module “Digest->new()” kód befecskendezés sérülékenység

CH azonosító

CH-5677

Angol cím

Perl Digest Module "Digest->new()" Code Injection Vulnerability

Felfedezés dátuma

2011.10.02.

Súlyosság

Közepes

Érintett rendszerek

Digest module
Perl

Érintett verziók

Perl Digest module 1.x

Összefoglaló

A Perl Digest moduljának olyan sérülékenysége vált ismertté, melyet kihasználva a támadók feltörhetik a sérülékeny modult használó alkalmazást.

Leírás

A sérülékenységet az okozza, hogy a “Digest->new()” függvény nem tisztázza megfelelően a bemeneti adatot, mielőtt egy “eval()” híváshoz használná. Ez kihasználható tetszőleges Perl kód futtatására.

A sérülékenység az 1.17 előtti verziókban jelentették.

Megoldás

Frissítsen a legújabb verzióra