PHP biztonsági vizsgálat megkerülés sérülékenységek

CH azonosító

CH-2929

Felfedezés dátuma

2010.02.26.

Súlyosság

Alacsony

Érintett rendszerek

PHP
PHP Group

Érintett verziók

PHP Group PHP 5.2.x

Összefoglaló

A PHP több olyan sérülékenységét jelentették, melyeket rosszindulatú felhasználók
kihasználhatnak egyes biztonsági előírások megkerülésére.

Leírás

A PHP több olyan sérülékenységét jelentették, melyeket rosszindulatú felhasználók
kihasználhatnak egyes biztonsági előírások megkerülésére.

  1. A munkamenet kiterjesztés egy hibája kihasználható a “safe_mode” és “open_basedir” beállítások megkerülésére.
  2. A “tempnam()” függvény érvényesítési hibáját felhasználható a “safe_mode”
    beállítás megkerülésére.
  3. A harmadik problémát elégtelen LCG entrópia okozza.

Megoldás

Frissítsen a legújabb verzióra