PHP puffer túlcsordulásos sérülékenység

CH azonosító

CH-9366

Angol cím

PHP "php_quot_print_encode()" Buffer Overflow Vulnerability

Felfedezés dátuma

2013.06.06.

Súlyosság

Közepes

Érintett rendszerek

PHP
PHP Group

Érintett verziók

PHP 5.3.x, 5.4.x

Összefoglaló

A PHP egy sérülékenységét jelentették, amit kihasználva a támadók feltörhetik a sérülékeny rendszert.

Leírás

A sérülékenységet a “php_quot_print_encode()” függvény (ext/standard/quot_print.c) egy hibája okozza, amely a paraméterként átadott string-ek feldolgozása során keletkezik, és amit kihasználva halom alapú puffer túlcsordulást lehet előidézni.

A sérülékenység sikeres kihasználása tetszőleges kód végrehajtását teszi lehetővé.

MEGJEGYZÉS: az 5.4.15 verzió egy sérülékenységét kihasználva összeomlást lehet előidézni, amely az MP3 fájlok mimetype-jának feldolgozása során következik be.

A sérülékenységet az 5.4.16 és 5.3.26 előtti verziókban jelentették.

Megoldás

Frissítsen a legújabb verzióra