phpMyAdmin cross-site scripting sérülékenység

CH azonosító

CH-3625

Angol cím

phpMyAdmin Unspecified Cross-Site Scripting Vulnerability

Felfedezés dátuma

2010.09.07.

Súlyosság

Alacsony

Érintett rendszerek

phpMyAdmin
phpMyAdmin Project

Érintett verziók

phpMyAdmin 3.x

Összefoglaló

 A phpMyAdmin egy sérülékenységét jelentették, amit kihasználva távoli támadók cross-site scripting (XSS) támadást indíthatnak.

 

Leírás

Egy bizonyos paraméter a setup script-nek történő átadás előtt nincs megfelelően ellenőrizve mielőtt visszakerül a felhasználóhoz. Ez kihasználható tetszőleges HTML és script kód futtatására a felhasználó böngészőjének munkamenetében az érintett oldallal kapcsolatosan.

MEGJEGYZÉS: a sikeres kihasználás feltétele, hogy ne kövesse a telepítési tanácsokat és a telepítési scriptek ne legyenek kitörölve a sikeres telepítés után.

A sérülékenység a 3.3.7 előtti verziókat érinti.

Megoldás

Frissítsen a legújabb verzióra