phpMyAdmin cross-site scripting sérülékenységei

CH azonosító

CH-1341

Felfedezés dátuma

2008.06.23.

Súlyosság

Alacsony

Érintett rendszerek

phpMyAdmin
phpMyAdmin Project

Érintett verziók

phpMyAdmin Project phpMyAdmin 1.x, 2.x

Összefoglaló

A phpMyAdmin olyan sérülékenységei váltak ismertté, melyeket kihasználva rosszindulatú támadók cross-site scripting támadásokat tudnak végrehajtani.

Leírás

A phpMyAdmin olyan sérülékenységei váltak ismertté, melyeket kihasználva rosszindulatú támadók cross-site scripting támadásokat tudnak végrehajtani.

A /libraries-ben található fájloknak meghatározatlan paraméterekkel átadott bevitel nincs megfelelően megtisztítva mielőtt visszakerül a felhasználóhoz. Ez kihasználható tetszőleges HTML és script kód futtatására a felhasználó böngészőjében egy érintett oldallal kapcsolatosan.

A sikeres kihasználás feltétele, hogy a “register_globals engedélyezve és a “.htaccess” támogatás tiltva legyen.

A sérülékenységek a 2.11.7-est megelőző verziókban találhatóak.

Megoldás

Frissítsen a legújabb verzióra