phpMyAdmin “setup.php” PHP kód befecskendezés sérülékenység

CH azonosító

CH-3511

Felfedezés dátuma

2010.08.19.

Súlyosság

Alacsony

Érintett rendszerek

phpMyAdmin
phpMyAdmin Project

Érintett verziók

phpMyAdmin 2.x

Összefoglaló

A phpMyAdmin olyan sérülékenysége vált ismertté, melyet kihasználva támadók feltörhetik a sérülékeny rendszert.

Leírás

A sérülékenység oka, hogy az alkalmazás nem ellenőrzi megfelelően a konfigurációs paramétereket a telepítés során. Ez kihasználható tetszőleges PHP kód befecskendezésére a phpMyAdmin konfigurációs fájljába.

Figyelem: A sikeres kihasználás feltétele, hogy ne kövesse a telepítési tanácsokat és a telepítési scriptek ne legyenek kitörölve a sikeres telepítés után.

A sérülékenység a 2.11.10.1 előtti verziókban található.

Megoldás

Frissítsen a legújabb verzióra