phpPgAdmin függvények script beszúrásos sérülékenysége

CH azonosító

CH-6633

Angol cím

phpPgAdmin Functions Script Insertion Vulnerability

Felfedezés dátuma

2012.03.29.

Súlyosság

Alacsony

Érintett rendszerek

N/A
phpPgAdmin

Érintett verziók

phpPgAdmin 5.x

Összefoglaló

A phpPgAdmin sérülékenysége vált ismertté, amelyet kihasználva a támadók script beszúrásos támadásokat hajthatnak végre.

Leírás

Bizonyos nem részletezett, függvényekkel kapcsolatos bemeneti adat nincs megfelelően megtisztítva, mielőtt felhasználásra kerülne. Ez kihasználható tetszőleges HTML és script kód futtatására a felhasználó böngésző munkamenetében, az érintett oldallal kapcsolatban, a káros tartalom megtekintésekor.

A sérülékenységet az 5.0.3. verzióban jelentették. Korábbi kiadások is érintettek lehetnek.

Megoldás

Frissítsen a legújabb verzióra