PostgreSQL CASE Expression alkalmazás szolgáltatásmegtagadásos sérülékenysége

CH azonosító

CH-13552

Angol cím

PostgreSQL CASE Expression Processing Denial of Service Vulnerability

Felfedezés dátuma

2016.09.06.

Súlyosság

Közepes

Érintett rendszerek

PostgreSQL
PostgreSQL Global Development Group

Érintett verziók

PostgreSQL 9.x

Összefoglaló

A PostgreSQL közepes kockázati besorolású sérülékenységei váltak ismertté, melyekkel a támadó az érintett rendszeren szolgáltatás-megtagadást érhet el. A sérülékenységeket kiküszöbölő megoldás már beszerezhető a gyártótól.

Leírás

A sérülékenység CASE feltételt tartalmazó SQL utasítással válhat kihasználhatóvá, amellyel az érintett szerver válaszképtelenné tehető.

Megoldás

Frissítsen a Postgresql 9.4.9-es verziójára.

Hivatkozások

Gyártói referencia: git.postgresql.org
Egyéb referencia: tools.cisco.com
Gyártói referencia: bugzilla.redhat.com
Gyártói referencia: rhn.redhat.com
CVE-2016-5423 - NVD CVE-2016-5423