PostgreSQL sebezhetőségek

CH azonosító

CH-13024

Angol cím

PostgreSQL vulnerabilities

Felfedezés dátuma

2016.02.11.

Súlyosság

Közepes

Érintett rendszerek

PostgreSQL Global Development Group

Érintett verziók

9.1.20, 9.2.15, 9.3.11, 9.4.6, illetve a 9.5.1-est megelőzők.

Összefoglaló

A PostgreSQL alapú adatbázisokat két sérülékenység veszélyezteti. Az egyik jogosulatlan hozzáférésre adhat módot, míg a másik szolgáltatásmegtagadásokhoz járulhat hozzá.

Leírás

A DoS támadásokat elősegítő sebezhetőség reguláris kifejezésekkel válhat kihasználhatóvá, amelyek végtelen ciklust eredményezhetnek.

A másik hiba pedig superuser jogok nélkül is lehetőséget adhat különféle konfigurációs paraméterek manipulálására. Ez esetben a támadónak rendelkeznie kell érvényes hozzáféréssel.

Megoldás

A 9.1.20, 9.2.15, 9.3.11, 9.4.6, illetve a 9.5.1 verziók már nem tartalmazzák a sebezhetőséget.