PostgreSQL többszörös sérülékenységek

CH azonosító

CH-8856

Angol cím

PostgreSQL Multiple Vulnerabilities

Felfedezés dátuma

2013.04.03.

Súlyosság

Alacsony

Érintett rendszerek

PostgreSQL
PostgreSQL Global Development Group

Érintett verziók

PostgreSQL 8.x, 9.x

Összefoglaló

A PostgreSQL olyan sérülékenységei váltak ismertté, amelyeket kihasználva a rosszindulatú felhasználók brute force támadásokat indíthatnak, megkerülhetnek egyes biztonsági szabályokat, valamint a támadók szolgáltatás megtagadást (DoS – Denial of Service) idézhetnek elő.

Leírás

  1. A szerver parancssori kapcsolóinak elemzésekor jelentkező hiba kihasználható a szerver adatkönyvtárában található fájlok megrongálására vagy megsemmisítésére egy adatbázis nevet tartalmazó speciálisan kialakított kéréssel, így a szolgáltatás elérhetetlenné válik.
    A sérülékenységet 9.2.4, 9.1.9 és 9.0.13 előtti verziókban ismerték fel.
  2. A contrib/pgcrypto függvények egy hibája miatt annak használata az elvártnál gyengébb véletlen számokat eredményez. A sérülékenység sikeres kihasználásához szükséges, hogy a postmaster “ssl = on” opcióval legyen használva.
    A sérülékenységet a 9.2.4, 9.1.9, 9.0.13 és 8.4.17 előtti verziókban ismerték fel.
  3. A core server komponensben lévő hiba miatt nincs megfelelően kezelve az aktuális felhasználó REPLICATION jogosultságának ellenőrzése, amely kihasználható a “pg_start_backup()” vagy “pg_stop_backup()” függvények hívására, és a biztonsági mentések szokásos menetének megállítására.
    A sérülékenységet a 9.2.4 és 9.1.9 verziókban ismerték fel.

Megjegyzés: A Linux és Mac OS X grafikus felületű telepítőkben lévő további két hiba kihasználható symlink támadásra és a superuser jelszó megszerzésére.

Megoldás

Frissítsen a legújabb verzióra