PUBLISH-iT PUI puffer túlcsordulásos sérülékenysége

CH azonosító

CH-10510

Angol cím

PUBLISH-iT PUI Processing Buffer Overflow Vulnerability

Felfedezés dátuma

2014.02.05.

Súlyosság

Magas

Érintett rendszerek

N/A

Érintett verziók

PUBLISH-iT 3.x

Összefoglaló

A Core Security felfedezte a PUBLISH-iT sebezhetőségét, amelyet kihasználva a támadók feltörhetik a felhasználó rendszerét.

Leírás

A sérülékenységet az okozza, hogy egy hiba feldolgozásakor a PUI fájlok kihasználhatóak puffer túlcsordulás előidézésére egy speciálisan erre a célra elkészített PUI fájl.

A sérülékenységet a 3.6d. verzióban jelentették, de más verziók is érintetek lehetnek.

Megoldás

Jelenleg nincs hivatalos megoldás.