PukiWiki Plus! XSS sérülékenység

CH azonosító

CH-6162

Angol cím

PukiWiki Plus! Unspecified Cross-Site Scripting Vulnerability

Felfedezés dátuma

2011.12.25.

Súlyosság

Alacsony

Érintett rendszerek

N/A
PukiWiki Plus!

Érintett verziók

PukiWiki Plus! 1.x

Összefoglaló

A PukiWiki Plus! egy sérülékenységét jelentették, amelyet kihasználva a támadók cross-site scripting (XSS/CSS) támadást hajthatnak végre.

Leírás

Egyes nem részletezett bemeneti adatokat nem megfelelően tisztítja meg a plugin/comment.inc.php, mielőtt visszakerülne a felhasználóhoz. Ezt kihasználva, tetszőleges HTML és script kódot lehet futtatni a felhasználó böngészőjének munkamenetében az érintett oldal vonatkozásában.

A sérülékenységet az 1.4.7 előtti verziókban jelentették.

Megoldás

A javítás elérhető az SVN tárolóból.