Puppet sérülékenységek

CH azonosító

CH-7182

Angol cím

Puppet Multiple Vulnerabilities

Felfedezés dátuma

2012.07.10.

Súlyosság

Alacsony

Érintett rendszerek

Puppet
Puppet Enterprise
Puppet Labs

Érintett verziók

Puppet 2.x
Puppet Enterprise 1.x, 2.x

Összefoglaló

A Puppet több sérülékenységét jelentették, amelyeket kihasználva a rosszindulatú, helyi felhasználók bizalmas információkat fedhetnek fel, a rosszindulatú felhasználók felfedhetnek és manipulálhatnak bizonyos bizalmas információkat, a támadók pedig megkerülhetnek egyes biztonsági szabályokat.

Leírás

  1. Bizonyos nem részletezett bemeneti adat nincs megfelelően ellenőrizve, mielőtt fájlok olvasásához felhasználásra kerülne. Ez kihasználható tetszőleges, lokális fájlok olvasására egy speciálisan formázott kéréssel.
  2. Bizonyos nem részletezett bemeneti adat nincs megfelelően ellenőrizve, mielőtt fájlok törléséhez felhasználásra kerülne. Ez kihasználható tetszőleges, lokális fájlok törlésére egy speciálisan formázott kéréssel.
    A sérülékenység sikeres kihasználása feltételezi, hogy a törlés engedélyezve van (alapértelmezésben tiltott).
  3. Az alkalmazás az utoljára futtatott riportot mindenki által olvasható módon tárolja, ami kihasználható például egy ügynök (agent) konfiguráció változásának felfedésére.
  4. A tanúsítvány aláírási mechanizmusban egy bemeneti adat érvényesítési hiba miatt nincs megfelelően ellenőrizve a tanúsítványban szereplő szövegsorrend. Ezt kihasználva az adminisztrátort rá lehet venni egy érvénytelen tanúsítvány aláírására.

A sérülékenységeket a Puppet 2.6.17 és 2.7.18 előtti, valamint a Puppet Enterprise 2.5.2 előtti verzióiban jelentették.

Megoldás

Frissítsen a legújabb verzióra