Ruby on Rails biztonsági puffer cross-site scripting sérülékenység

CH azonosító

CH-5015

Angol cím

Ruby on Rails Safe Buffer Cross-Site Scripting Weakness

Felfedezés dátuma

2011.06.07.

Súlyosság

Alacsony

Érintett rendszerek

Rails Core Team
Ruby on Rails

Érintett verziók

Ruby on Rails 2.3.x, 3.0.x

Összefoglaló

A Ruby on Rails olyan sérülékenysége vált ismertté, amelyet a támadók kihasználhatnak cross-site scripting vagy script beszúrás támadások kezdeményezésére.

Leírás

A sérülékenység oka, hogy bizonyos eljárások (pl. “link_to”,”sub!”) nem  megfelelően veszik figyelembe a stringek “HTML safe” jelölését. Ez a nem megfelelően ellenőrzött bemenet felhasználó részére történő visszaküldését eredményezheti, és kihasználható az érintett oldal felhasználói böngésző munkamenetében történő tetszőleges HTML és script kód futtatására.

A sérülékenységet a 3.0.7. és 2.3.11. verziókban ismerték fel, de más verziók is érintettek lehetnek.

Megoldás

Frissítsen a legújabb verzióra