Ruby Phusion Passenger Gem biztonsági problémák

CH azonosító

CH-10474

Angol cím

Ruby Phusion Passenger Gem Temporary Directory Creation Race Condition Security Issue

Felfedezés dátuma

2014.01.30.

Súlyosság

Alacsony

Érintett rendszerek

Ruby

Érintett verziók

Phusion Passenger gem for Ruby 4.x

Összefoglaló

A ruby Phusion Passenger gem biztonségi problémái váltak ismertté, melyeket kihasználva a támadók bizonyos információkat manipulálhatnak.

Leírás

A biztonsági problémát, egy olyan hiba okozza, amikor  bizonyos ideiglenes könyvtárak létrehozásra kerülnek, és ez kihasználható hogy manipuláljanak egyes fájlokat symlink támadással.

A problémát a 4.0.38. előtti verziókból jelentették.

Megoldás

Frissítsen a legújabb verzióra

Megoldás

Frissítsen 4.0.38. verzióra.

Hivatkozások

Gyártói referencia: github.com
Egyéb referencia: www.openwall.com
SECUNIA 56617
CVE-2014-1832 - NVD CVE-2014-1832