SAP NetWeaver cross-site scripting és cross-site request forgery sérülkenységek

CH azonosító

CH-7940

Angol cím

SAP NetWeaver Cross-Site Scripting and Request Forgery Vulnerabilities

Felfedezés dátuma

2012.11.13.

Súlyosság

Alacsony

Érintett rendszerek

NetWeaver
SAP

Érintett verziók

SAP NetWeaver 7.x

Összefoglaló

Az SAP NetWeaver két sérülékenysége vált ismertté, amelyeket kihasználva a támadók cross-site scripting (XSS/CSS) és cross-site request forgery (XSRF/CSRF) támadásokat hajthatnak végre.

Leírás

  1. Bizonyos bemeneti adat nincs megfelelően megtisztítva a Mobile RFID alkalmazásban, mielőtt a felhasználó számára visszaadásra kerülne. Ezt kihasználva, tetszőleges HTML és script kódot lehet futtatni a felhasználó böngészőjének munkamenetében az érintett oldal vonatkozásában.
  2. Az alkalmazás lehetővé teszi a felhasználóknak bizonyos műveletek elvégzését HTTP kérések segítségével anélkül, hogy ellenőrizné azok érvényességét. Ez kihasználható bizonyos nem részletezett tevékenységek végrehajtására, ha a bejelentkezett felhasználó meglátogat egy káros weboldalt.
    A sérülékenységet a 7.x verzióban jelentették, de más kiadások is érintettek lehetnek.

Megoldás

Frissítsen a legújabb verzióra