SAP NetWeaver információ felfedéses és cross-site scripting sérülékenységek

CH azonosító

CH-7700

Angol cím

SAP NetWeaver Information Disclosure and Cross-Site Scripting Vulnerabilities

Felfedezés dátuma

2012.10.04.

Súlyosság

Alacsony

Érintett rendszerek

NetWeaver
SAP

Érintett verziók

SAP NetWeaver 7.x

Összefoglaló

Az SAP NetWeaver olyan sérülékenységei váltak ismertté, amelyeket a támadók kihasználhatnak bizonyos bizalmas adatok megszerzésére és cross-site scripting (XSS/CSS) támadások kezdeményezésére.

Leírás

  1. A streaming szerver kisalkalmazás egy nem részletezett hibáját jelentették.
  2. Bizonyos nem részletezett bemeneti adat nincs megfelelően megtisztítva a Mobile Infrastructure Web Console-ban, mielőtt a felhasználó részére visszaküldésre kerülne. Ezt kihasználva, tetszőleges HTML és script kódot lehet futtatni a felhasználó böngészőjének munkamenetében az érintett oldal vonatkozásában.

A sérülékenységet a 7.x verzióban ismerték fel, de más kiadások is érintettek lehetnek.

Megoldás

Telepítse a javítócsomagokat