SQL Buddy cross-site scripting sérülékenységek

CH azonosító

CH-6428

Angol cím

SQL Buddy Multiple Cross-Site Scripting Vulnerabilities

Felfedezés dátuma

2012.02.16.

Súlyosság

Alacsony

Érintett rendszerek

N/A
SQL Buddy

Érintett verziók

SQL Buddy 1.x

Összefoglaló

Az SQL Buddy több sérülékenysége vált ismertté, amelyeket kihasználva a támadók cross-site scripting (XSS/CSS) támadásokat hajthatnak végre.

Leírás

A login.php-nek a “HOST”, “USER” és “DATABASE” paramétereken keresztül, valamint a dboverview.php-nek a “db” paraméteren keresztül átadott bemeneti adatok nincs megfelelően megtisztítva, mielőtt a  felhasználó számára visszaadásra kerülne. Ez kihasználható tetszőleges HTML és script kód futtatására a felhasználó böngészőjének munkamenetében, az érintett oldallal kapcsolatban.

A sérülékenységeket az 1.3.3 verzióban jelentették. Más kiadások is érintettek lehetnek.

Megoldás

Javítsa a forráskódot a bemenet megfelelő ellenőrzése érdekében