SuSE biztonsági frissítés javítja az Asterisk kód futtatási és DoS sebezhetőségeit

CH azonosító

CH-222

Felfedezés dátuma

2006.11.18.

Súlyosság

Magas

Érintett rendszerek

Linux
SUSE

Érintett verziók

SUSE Linux 9.3, 10, 10.1

Összefoglaló

A SUSE kiadta az asterisk frissítését. Ez javít több olyan sebezhetőséget, melyet rosszindulatú támadók szolgáltatás megtagadás (DoS) okozására vagy a rendszer feltörésére használhattak fel.

Leírás

A SuSE megjelentette javító csomagjait az Asterisk-ben azonosított többféle sebezhetőség megerősítésére. Ezeket a hiányosságokat kiaknázhatták a támadók tetszőleges parancsok futtatására vagy szolgáltatás megtagadás okozására.

  1. A chan_skinny.c “get_input()” függvényének egész túlcsordulás hibáját kihasználva halom túlcsordulás okozható az Asterisk Skinny channel drivernek küldött, különlegesen kialakított csomagokkal.
  2. A szabálytalan SIP csomagok kezelésének meghatározatlan hibáit kihasználva pl. leállítható az Asterisk, csatornák nyithatók, feltölthetők a várakozási sorok, log fájlok és a hangüzenetek rendelkezésére álló hely különlegesen kialakított csomagokkal.

Megoldás

Frissítsen a legújabb verzióra