TYPO3 phpMyAdmin bővítmény átirányítás és cross-site scripting sérülékenységek

CH azonosító

CH-4945

Angol cím

TYPO3 phpMyAdmin Extension Redirection and Cross-Site Scripting Vulnerabilities

Felfedezés dátuma

2011.05.23.

Súlyosság

Alacsony

Érintett rendszerek

TYPO3
phpMyAdmin component

Érintett verziók

phpMyAdmin (phpmyadmin) Extension for TYPO3 4.x

Összefoglaló

A phpMyAdmin extension for TYPO3 olyan sérülékenységei váltak ismertté, amelyeket a támadók kihasználhatnak hamisítás (spoofing) és cross-site scripting (CSS/XSS) támadások kezdeményezésére.

Leírás

  1. Bizonyos nem részletezett bemeneti adat nem kerül megfelelően ellelnőrzésre, mielőtt a felhasználók átirányításra kerülnének. Ez kihasználható egy felhasználó tetszőleges weboldalra történő átirányítására, amennyiben a felhasználó követ egy megbízható domain-en hostolt script-re mutató speciális hivatkozást.
  2. Egy tetszőleges táblanévvel átadott bemeneti adat nem kerül megfelelően ellenőrzésre, mielőtt a felhasználó részére visszaküldésre kerülne. Ez kihasználható tetszőleges HTML és script kód beszúrására, amely az érintett oldal felhasználói böngésző munkamenetében kerül lefuttatásra, amikor a rosszindulatú adat megtekintésre kerül.

További információk:

A sérülékenységeket a 4.10.3. és megelőző verziókban jelentették.

Megoldás

Frissítsen a 4.11.0. verzióra.