Ubuntu overlayfs sérülékenysége

CH azonosító

CH-12341

Angol cím

Ubuntu overlayfs vulnerability

Felfedezés dátuma

2015.06.15.

Súlyosság

Magas

Érintett rendszerek

Linux
Ubuntu

Érintett verziók

Ubuntu 12.04, 14.04, 14.10, 15.04

Összefoglaló

A jelenleg támogatott összes Ubuntu verziót érintő sérülékenység a jogosultságok root szintre történő kiterjesztését teszi lehetővé.

Leírás

Az overlayfs fájlrendszer hibásan ellenőrzi a fájljogosultságokat amikor új fájlt hozunk létre a felsőbb fájlrendszerekben. Egy kernelmódban futó folyamat CONFIG_USER_NS=y beállításával ez kihasználható ha az overlayfs FS_USERNS_MOUNT flagje be van állítva (engedélyezi az overlayfs csatolását jogosulatlan namespace-ben). Ez a beállítás alapértelmezés szerint sérülékeny az Ubuntu 12.04, 14.04, 14.10, és 15.04-es verzióiban.

Megoldás

Telepítse a javítócsomagokat

Megoldás

Amennyiben nem használja az Ubuntu overlayfs funkcióit korlátozhatja a problémát: Törölje vagy tegye feketelistára az overlayfs.ko-t ill. overlay.ko-t.

Hivatkozások

CVE-2015-1328 - NVD CVE-2015-1328
Gyártói referencia: www.ubuntu.com
Gyártói referencia: www.ubuntu.com
Gyártói referencia: www.ubuntu.com
Gyártói referencia: www.ubuntu.com
Gyártói referencia: www.ubuntu.com
Gyártói referencia: www.ubuntu.com
Gyártói referencia: www.ubuntu.com
Gyártói referencia: www.ubuntu.com
Egyéb referencia: people.canonical.com