VLC Media Player libmodplug puffer túlcsordulási sérülékenységek

CH azonosító

CH-4862

Angol cím

VLC Media Player libmodplug Buffer Overflow Vulnerabilities

Felfedezés dátuma

2011.05.03.

Súlyosság

Magas

Érintett rendszerek

VLC Media Player
VideoLAN

Érintett verziók

VLC Media Player 1.x

Összefoglaló

A VLC Media Player olyan sérülékenységei váltak ismertté, amelyeket a támadók kihasználhatnak a felhasználó sérülékeny rendszerének feltörésére.

Leírás

A sérülékenységeket az alkalmazásban használt libmodplug könyvtár sérülékeny verziója okozza.

A sérülékenységekről bővebb információ:
CERT-Hungary CH-4861

Megjegyzés: Ez csak az előre fordított verziókat érinti.

A sérülékenységeket a Windows operációs rendszeren futtatott 1.1.9. verzióban jelentették. Más verziók is érintettek lehetnek.

Megoldás

Ne nyisson meg nem megbízható forrásból származó fájlokat.