WHMCompleteSolution PayPal és Google Checkout bővítmény sérülékenységek

CH azonosító

CH-8185

Angol cím

WHMCompleteSolution PayPal and Google Checkout Modules Vulnerabilities

Felfedezés dátuma

2013.01.03.

Súlyosság

Alacsony

Érintett rendszerek

WHMCS Ltd
WHMCompleteSolution

Érintett verziók

WHMCompleteSolution 4.x, 5.x

Összefoglaló

A WHMCompleteSolution olyan sérülékenységei váltak ismertté, amelyeket kihasználva a rosszindulatú felhasználók megkerülhetnek bizonyos védelmi szabályokat és SQL befecskendezéses (SQL injection) támadásokat hajthatnak végre.

Leírás

  1. Paypal tranzakciók paypal bővítmény belüli kezelésekor fellépő hiba kihasználható az alkalmazásban beállított fiókon kívül más fiókok elérésére is.
    A sérülékenység sikeres kihasználásához a paypal bővítmény engedélyezése szükséges.
  2. A Google checkout bővítménynek átadott egyes bemeneti adatok nincsenek megfelelően megtisztítva az SQL lekérdezésekben történő használat előtt. Ez kihasználható az SQL lekérdezések módosítására tetszőleges SQL kód befecskendezésével.
    A sérülékenység sikeres kihasználásához a Google checkout bővítmény engedélyezése szükséges.

A sérülékenységek a 4.5.3 és az 5.1.3 előtti verziókat érintik.

Megoldás

Frissítsen a legújabb verzióra