Wireshark szolgáltatás megtagadásos sérülékenységek

CH azonosító

CH-9230

Angol cím

Wireshark Multiple Denial of Service Vulnerabilities

Felfedezés dátuma

2013.05.19.

Súlyosság

Közepes

Érintett rendszerek

Wireshark
Wireshark Foundation

Érintett verziók

Wireshark 1.x

Összefoglaló

A Wireshark több sérülékenységét jelentették, amelyeket kihasználva a támadók szolgáltatás megtagadást (DoS – Denial of Service) idézhetnek elő.

Leírás

  1. A RELOAD dissector (dissectors/packet-reload.c) egy hibáját kihasználva végtelen ciklust és a processzor erőforrásainak teljes kimerítését lehet előidézni speciálisan elkészített csomagok segítségével. Ez a sérülékenység az alábbihoz kapcsolódik CERT-Hungary CH-8650 (5. pont).
  2. A GTPv2 dissector (dissectors/packet-gtpv2.c) egy hibáját kihasználva összeomlást lehet előidézni speciálisan elkészített csomagok segítségével.
  3. Az ASN.1 BER dissector egy hibáját kihasználva összeomlást lehet előidézni speciálisan elkészített csomagok segítségével. Ez a sérülékenység az 1.6.15 és 1.8.7 verziót is érinti.
  4. A PPP CCP dissector (dissectors/packet-ppp.c) egy hibáját kihasználva összeomlást lehet előidézni speciálisan elkészített csomagok segítségével.
  5. A DCP ETSI dissector (dissectors/packet-dcp-etsi.c) egy hibáját kihasználva összeomlást lehet előidézni speciálisan elkészített csomagok segítségével.
  6. A MPEG DSM-CC dissector (dissectors/packet-mpeg-dsmcc.c) egy hibáját kihasználva összeomlást lehet előidézni speciálisan elkészített csomagok segítségével.
  7. A Websocket dissector (dissectors/packet-websocket.c) egy hibáját kihasználva összeomlást lehet előidézni speciálisan elkészített csomagok segítségével.
  8. A MySQL dissector (dissectors/packet-mysql.c) egy hibáját kihasználva végtelen ciklust és a processzor erőforrásainak teljes kimerítését lehet előidézni speciálisan elkészített csomagok segítségével.
  9. A ETCH dissector (dissectors/packet-etch.c) egy hibáját kihasználva végtelen ciklust és a processzor erőforrásainak teljes kimerítését lehet előidézni speciálisan elkészített csomagok segítségével.

Az 1., 2., illetve a 4 – 9. közti sérülékenységeket az 1.8.7 előtti verziókban jelentették.

Megoldás

Frissítsen a legújabb verzióra