WordPress Adsense Extreme bővítmény “adsensextreme[lang]” fájl beillesztési sérülékenység

CH azonosító

CH-5598

Angol cím

WordPress Adsense Extreme Plugin "adsensextreme[lang]" File Inclusion Vulnerability

Felfedezés dátuma

2011.09.20.

Súlyosság

Magas

Érintett rendszerek

Adsense Extreme plugin
WordPress

Érintett verziók

WordPress Adsense Extreme Plugin 1.x

Összefoglaló

A  WordPress Adsense Extreme bővítmény olyan sérülékenysége vált ismertté, amelyet a támadók kihasználhatnak a sérülékeny rendszer feltörésére.

Leírás

Az “adsensextreme[lang]” POST paraméteren keresztül a wp-content/plugins/adsense-extreme/adsensextremeadminpage.php-nek átadott bemeneti adat nem kerül megfelelően ellenőrzésre, mielőtt a fájlokba beillesztésére kerülne felhasználásra. Ez kihasználható helyi vagy küldő forrásokból származó tetszőleges fájlok beillesztésére.

A sérülékenységet az 1.0.3. verzióban ismerték fel, de megelőző verziók is érintettek lehetnek.

Megoldás

Frissítsen az 1.0.4. verzióra.