WordPress All in One SEO Pack bővítmény sérülékenysége

CH azonosító

CH-13413

Angol cím

All in One SEO Pack WordPress plugin vulnerability

Felfedezés dátuma

2016.07.14.

Súlyosság

Magas

Érintett rendszerek

All in One SEO Pack
WordPress

Érintett verziók

2.3.6.1 és korábbiak.

Összefoglaló

A WordPress egyik legnépszerűbb bővítménye, az All in One SEO Pack keresőoptimalizáló kapcsán egy magas kockázati besorolású sérülékenységre derült fény, amely alkalmas lehet arra, hogy egy rosszindulatú támadó Cross Site Scripting (XSS) támadást hajtson végre és átvehesse az irányítást a támadott oldal felett. A sérülékenységet kiküszöbölő megoldás már beszerezhető a gyártótól.

Leírás

A biztonsági hiba a Track Bot Blocker funkciót érinti és a bejövő kérések nem megfelelő ellenőrzéséből fakad. 

A kihasználás során a támadó elküld egy HTTP kérésbe ágyazott káros JavaScript kódot. A TBB – amennyiben engedélyezve van – kiszűri ezt, de minden blokkolt kérést logol és az admin panelen képes megjeleníteni. Ha az oldal adminisztrátora ezt megtekinti, a káros kód lefut, aminek következményeként a támadó hozzáférhet a session azonosítókhoz és az adminisztrátor nevében járhat el: például létrehozhat új admin fiókot.

Megoldás

Frissítsen a legújabb verzióra