WordPress Annonces Plugin “abspath” és “mainPluginFile” fájl befoglalási sérülékenységek

CH azonosító

CH-5583

Angol cím

WordPress Annonces Plugin "abspath" and "mainPluginFile" File Inclusion Vulnerabilities

Felfedezés dátuma

2011.09.19.

Súlyosság

Magas

Érintett rendszerek

Annonces plugin
WordPress

Érintett verziók

WordPress Annonces Plugin 1.x

Összefoglaló

A WordPress Annonces Plugin olyan sérülékenységei váltak ismertté, amelyet kihasználva a támadók feltörhetik a sérülékeny rendszert.

Leírás

  1. Az “abspath” paraméteren keresztül a wp-content/plugins/annonces/includes/lib/photo/uploadPhoto.php részére átadott bemeneti adat nincsen megfelelően ellenőrizve fájlok befoglalása előtt. Ez kihasználható tetszőleges fájlok befoglalására helyi és kiterjesztett erőforrásokból.
  2. A “mainPluginFile” paraméteren keresztül awp-content/plugins/annonces/includes/lib/photo/uploadPhoto.php részére (amikor az “abspath” beállítása pl.: “../../../../../../”) átadott bemeneti adat nincsen megfelelően ellenőrizve fájlok befoglalása előtt. Ez kihasználható fájlok befoglalására helyi és kiterjesztett erőforrásokból.

A sérülékenységeket az 1.2.0.0-ás verzióban jelentették, továbbá egyéb verziók is érintettek lehetnek.

Megoldás

Javítsa a forráskódot a bemenet megfelelő ellenőrzése érdekében