WordPress Backup Plugin sérülékenység

CH azonosító

CH-7276

Angol cím

WordPress Backup Plugin Backup Disclosure Vulnerability

Felfedezés dátuma

2012.07.24.

Súlyosság

Közepes

Érintett rendszerek

Backup plugin
WordPress

Érintett verziók

WordPress Backup Plugin 2.x

Összefoglaló

A WordPress Backup bővítményének sérülékenységét jelentették, amelyet a támadók kihasználhatnak érzékeny információk közzétételére.

Leírás

A sérülékenységet az okozza, hogy az alkalmazás engedélyezi az adatbázis mentés kéréseket a tanúsítványok ellenőrzése nélkül (ha a “backup” GET paraméter be van állítva). Ez kihasználható az adatbázis mentés letöltésére és érzékeny információk kiszivárogtatására.

A sérülékenységet a 2.1 verziót megelőző verziókban jelentették.

Megoldás

Frissítsen a legújabb verzióra