WordPress Cloudsafe365 bővítmény sérülékenységek

CH azonosító

CH-7465

Angol cím

WordPress Cloudsafe365 Plugin Multiple Vulnerabilities

Felfedezés dátuma

2012.08.27.

Súlyosság

Közepes

Érintett rendszerek

Cloudsafe365 Plugin
WordPress

Érintett verziók

WordPress Cloudsafe365 bővítmény 1.x

Összefoglaló

A WordPress Cloudsafe365 bővítmény olyan sérülékenységei váltak ismertté, amelyeket a támadók kihasználhatnak cross-site scripting (XSS/CSS) támadások indítására és bizalmas információk felfedésére.

Leírás

  1. A “file”, “line” és “malware” paraméterekkel a wp-content/plugins/cloudsafe365-for-wp/admin/editor/cs365_edit.php részére átadott bemeneti adat nincs megfelelően megtisztítva, mielőtt a felhasználó részére visszaküldésre kerülne. Ezt kihasználva, tetszőleges HTML és script kódot lehet futtatni a felhasználó böngészőjének munkamenetében az érintett oldal vonatkozásában.
  2. A “file” paraméterrel a wp-content/plugins/cloudsafe365-for-wp/admin/editor/cs365_edit.php részére átadott bemeneti adat nincs megfelelően ellenőrizve, mielőtt fájlok megjelenítéséhez felhasználásra kerül. Ezt kihasználva könyvtárbejárás támadásokkal tetszőleges fájlokat lehet felfedni.

A sérülékenységeket az 1.47 előtti verziókban ismerték fel.

Megoldás

Frissítsen a legújabb verzióra