WordPress CMS Tree Page View bővítmény “cms_tpv_view” cross-site scripting sérülékenység

CH azonosító

CH-6594

Angol cím

WordPress CMS Tree Page View Plugin "cms_tpv_view" Cross-Site Scripting Vulnerability

Felfedezés dátuma

2012.03.26.

Súlyosság

Alacsony

Érintett rendszerek

CMS Tree Page View plugin
WordPress

Érintett verziók

WordPress CMS Tree Page View bővítmény 0.x

Összefoglaló

A WordPress CMS Tree Page View bővítmény olyan sérülékenysége vált ismertté, amelyeket a támadók kihasználhatnak cross-site scripting (XSS/CSS) támadások kezdeményezésére.

Leírás

A wp-admin/edit.php-ben a “cms_tpv_view” paraméter részére átadott bemenet (amikor “post_type” értéke “page” és “page” értéke “cms-tpv-page-page”) nem kerül megfelelően ellenőrzésre a wp-content/plugins/cms-tree-page-view/functions.php-ben található “cms_tpv_admin_head()” függvényben, mielőtt a felhasználó részére visszaküldésre kerülne. Ez kihasználható a felhasználó böngészőjének munkamenetében történő tetszőleges HTML és script kód futtatására, az érintett oldallal kapcsolatosan.

A sérülékenységet a 0.8.8. verzióban ismerték fel, de korábbi verziók is érintettek lehetnek.

Megoldás

Frissítsen a legújabb verzióra