WordPress custom tables bővítmény cross-site scripting sérülékenység

CH azonosító

CH-7148

Angol cím

WordPress custom tables Plugin "key" Cross-Site Scripting Vulnerability

Felfedezés dátuma

2012.07.05.

Súlyosság

Alacsony

Érintett rendszerek

WordPress
custom tables Plugin

Érintett verziók

WordPress custom tables Plugin 3.x

Összefoglaló

A WordPress custom tables bővítmény olyan sérülékenysége vált ismertté, amelyet a támadók kihasználhatnak cross-site scripting (XSS/CSS) támadások kezdeményezésére.

Leírás

Az “key” paraméterrel a wp-content/plugins/custom-tables/iframe.php részére átadott bemeneti adat nincs megfelelően megtisztítva, mielőtt a felhasználó részére visszaküldésre kerülne. Ezt kihasználva, tetszőleges HTML és script kódot lehet futtatni a felhasználó böngészőjének munkamenetében az érintett oldal vonatkozásában.

A sérülékenységet az 3.4.4 verzióban jelentették, de más kiadások is érintettek lehetnek.

Megoldás

Ismeretlen