WordPress FeedList Plugin “i” cross-site scripting sérülékenység

CH azonosító

CH-3911

Angol cím

WordPress FeedList Plugin "i" Cross-Site Scripting Vulnerability

Felfedezés dátuma

2010.11.07.

Súlyosság

Alacsony

Érintett rendszerek

FeedList plugin
WordPress

Érintett verziók

WordPress FeedList Plugin 2.x

Összefoglaló

A WordPress FeedList plugin egy sérülékenységét fedezték fel, amelyet a támadók kihasználva cross-site scripting (XSS/CSS) támadásokat okozhatnak.

Leírás

Az “i” paraméternek átadott bemenei adat a wp-content/plugins/feedlist/handler_image.php-ben nincsenek megfelelően megtisztítvaa felhasználónak történő visszaadás előtt. Ez kihasználható tetszőleges HTML és script kód futtatására a felhasználó böngészőjének munkamenetében az érintett oldallal kapcsolatosan.

A sérülékenységet a 2.60.01-es verzióban igazolták. Más verziók is érintettek lehetnek.

Megoldás

Javítsa a forráskódot a bemenet megfelelő ellenőrzése érdekében