WordPress Flowplayer Plugin URL cross-site scripting sérülékenység

CH azonosító

CH-5727

Angol cím

WordPress Flowplayer Plugin URL Cross-Site Scripting Vulnerability

Felfedezés dátuma

2011.10.06.

Súlyosság

Alacsony

Érintett rendszerek

Flowplayer plugin
WordPress

Érintett verziók

WordPress Flowplayer Plugin 1.x

Összefoglaló

A WordPress Flowplayer plugin egy sérülékenysége vált ismertté, amelyet kihasználva a támadók cross-site scripting (CSS/XSS) támadásokat hajthatnak végre.

Leírás

A wp-content/plugins/fv-wordpress-flowplayer/view/frontend-head.php részére URL-ben átadott bemeneti adat nincs megfelelően megtisztítva, mielőtt a felhasználóhoz visszakerülne. Ez kihasználható tetszőleges HTML és script kód beszúrására, melyek lefuttatásra kerülnek a felhasználó böngészőjének munkamenetében, az érintett oldallal kapcsolatosan.

A sérülékenységet az 1.2.11 verzióban jelentették és az 1.2.4 verzióban is igazolták. Korábbi verziók szintén érintettek lehetnek.

Megoldás

Frissítsen az 1.2.12 vagy újabb verzióra.