WordPress Font Uploader Plugin fájl feltöltés sérülékenység

CH azonosító

CH-7000

Angol cím

Wordpress Font Uploader Plugin Arbitrary File Upload Vulnerability

Felfedezés dátuma

2012.06.06.

Súlyosság

Magas

Érintett rendszerek

WordPress

Érintett verziók

WordPress Font Uploader Plugin 1.x

Összefoglaló

A WordPress Font Uploader Plugin olyan sérülékenysége vált ismertté, amelyet kihasználva a támadók feltörhetik a sérülékeny rendszert.

Leírás

A sérülékenységet az okozza, hogy a wp-content/plugins/font-uploader/font-upload.php script nem megfelelően érvényesíti egy feltöltött fájl kiterjesztését. Ez kihasználható tetszőleges PHP kód futtatására, ha olyan PHP fájlt töltenek fel, amihez “.ttf” vagy “.otf”  kiterjesztést fűztek hozzá.

A sikeres kihasználás feltétele, hogy az Apache úgy legyen konfigurálva, hogy ne kezelje a “.ttf” vagy “.otf” kiterjesztésű médiafájlok mime-type-ját (alapértelmezés szerint nem kezeli).

A sérülékenységet az 1.2.4 verzióban jelentették, de egyéb kiadások is érintettek lehetnek.

Megoldás

Javítsa a forráskódot a bemenet megfelelő ellenőrzése érdekében