WordPress Front End Upload Plugin fájl feltöltés sérülékenység

CH azonosító

CH-6997

Angol cím

WordPress Front End Upload Plugin Arbitrary File Upload Vulnerability

Felfedezés dátuma

2012.06.07.

Súlyosság

Közepes

Érintett rendszerek

Front End Upload Plugin
WordPress

Érintett verziók

WordPress Front End Upload Plugin 0.x

Összefoglaló

A WordPress Front End Upload Plugin olyan sérülékenysége vált ismertté, amelyet kihasználva a támadók feltörhetik a sérülékeny rendszert.

Leírás

A sérülékenységet a wp-content/plugins/front-end-upload/upload.php script egy hibája okozza, amely lehetővé teszi fájlok feltöltését tetszőleges kiterjesztéssel egy webroot-on belüli könyvtárba. Ez kihasználható tetszőleges PHP kód futtatására kártékony PHP script feltöltésével.

A sikeres kihasználás feltétele, hogy a plugin telepítve és deaktiválva legyen.

A sérülékenység a 0.5.3 verzióban található, de egyéb kiadások is érintettek lehetnek.

Megoldás

Korlátozza a hozzáférést a wp-content/plugins/front-end-upload/upload.php scripthez vagy a wp-content/plugins/front-end-upload/FEU_DESTINATION_DIR/ könyvtárhoz (pl. htaccess segítségével)!