WordPress Google Doc Embedder bővítmény sérülékenység

CH azonosító

CH-8184

Angol cím

WordPress Google Doc Embedder Plugin Arbitrary File Disclosure Vulnerability

Felfedezés dátuma

2013.01.02.

Súlyosság

Közepes

Érintett rendszerek

Google Doc Embedder Plugin
WordPress

Érintett verziók

WordPress Google Doc Embedder Plugin 2.x

Összefoglaló

A WordPress Google Doc Embedder bővítmény olyan sérülékenysége vált ismertté, amelyet a támadók kihasználhatnak bizalmas információk felfedésére.

Leírás

A wp-content/plugins/google-document-embedder/libs/pdf.php részére a “file” paraméternek átadott bemeneti adat (amikor “fn” érvényes értéket tartalmaz) nincs megfelelően ellenőrizve, mielőtt fájlok megjelenítésében kerülne felhasználásra. Ezt kihasználva könyvtárbejárásos támadással tetszőleges fájlok tartalmát lehet megszerezni.
 
A sérülékenységet a 2.4.6 verzióban ismerték fel, de más kiadások is érintettek lehetnek.

Megoldás

Frissítsen a legújabb verzióra