WordPress GRAND FlAGallery bővítmény SQL befecskendezéses sérülékenység

CH azonosító

CH-9151

Angol cím

WordPress GRAND FlAGallery Plugin "gid" SQL Injection Vulnerability

Felfedezés dátuma

2013.05.07.

Súlyosság

Alacsony

Érintett rendszerek

GRAND FlAGallery Plugin
WordPress

Érintett verziók

Wordpress GRAND FlAGallery Plugin (2.x)

Összefoglaló

A WordPress GRAND FlAGallery bővítmény egy sérülékenységét jelentették, amit kihasználva a rosszindulatú felhasználók SQL befecskendezéses (SQL injection) támadásokat hajthatnak végre.

Leírás

Egy poszt “[flagallery]” tag-jének “gid” paraméterén keresztül átadott bemeneti adat nem megfelelően van megtisztítva, mielőtt SQL lekérdezésben felhasználásra kerülne. Ezt kihasználva módosítani lehet az SQL lekérdezést tetszőleges SQL parancs befecskendezésével.

A sérülékenység sikeres kihasználásához “Editor” jogosultság szükséges.

A sérülékenységet a 2.55 verzióban jelentették, de korábbi kiadások is érintettek lehetnek.

Megoldás

Frissítsen a legújabb verzióra