WordPress KSES könyvtár script beszúrás sérülékenysége

CH azonosító

CH-4149

Angol cím

WordPress KSES Library Script Insertion Vulnerability

Felfedezés dátuma

2010.12.29.

Súlyosság

Alacsony

Érintett rendszerek

WordPress

Érintett verziók

WordPress 3.x

Összefoglaló

A WordPress olyan sérülékenységét jelentették, amelyet a rosszindulatú felhasználók kihasználva script beszúrásos támadásokat indíthatnak.

Leírás

Bizonyos meghatározatlan bemenet nincs megfelelően ellenőrizve a KSES könyvtárban, mielőtt megjelenítésre kerülne. Ezt kihasználva, tetszőleges HTML és script kódot lehet beszúrni a felhasználó böngészője által megjelenített munkafolyamatba, az érintett oldal vonatkozásában, a kártékony adatok megtekintés során.

A sérülékenységet a 3.0.4 előtti verzióknál jelentették.

Megoldás

Frissítsen a legújabb verzióra