WordPress Lazyest Gallery plugin “image” cross-site scripting sérülékenység

CH azonosító

CH-4527

Angol cím

WordPress Lazyest Gallery Plugin "image" Cross-Site Scripting Vulnerability

Felfedezés dátuma

2011.03.09.

Súlyosság

Alacsony

Érintett rendszerek

Lazyest Gallery plugin
WordPress

Érintett verziók

WordPress Lazyest Gallery plugin 1.x

Összefoglaló

A WordPress Lazyest Gallery bővítményének olyan sérülékenységét jelentették, amelyet a támadók kihasználva cross-site scripting (CSS/XSS) támadásokat hajthatnak végre.

Leírás

Az “image” paraméterrel a wp-content/plugins/lazyest-gallery/lazyest-popup.php-nek átadott bemenet nincs megfelelően ellenőrizve, mielőtt visszakerül a felhasználóhoz. Ez kihasználható tetszőleges HTML és script kód futtatására a felhasználó böngésző munkamenetében, az érintett oldallal kapcsolatosan.

A sérülékenységet a 1.0.28. verzióban jelentették. Más verziók is érintettek lehetnek.

Megoldás

Javítsa a forráskódot a bemenet megfelelő ellenőrzése érdekében