WordPress Local Market Explorer Plugin “api-key” cross-site scripting sérülékenysége

CH azonosító

CH-4460

Angol cím

WordPress Local Market Explorer Plugin "api-key" Cross-Site Scripting Vulnerability

Felfedezés dátuma

2011.02.27.

Súlyosság

Alacsony

Érintett rendszerek

Local Market Explorer plugin
WordPress

Érintett verziók

WordPress Local Market Explorer Plugin 3.x

Összefoglaló

A WordPress Local Market Explorer bővítményének olyan sérülékenységét jelentették, amelyet a támadók kihasználva cross-site scripting (XSS/CSS) támadásokat hajthatnak végre.

Leírás

Az “api-key” paraméter által átadott bemeneti adat a wp-content/plugins/local-market-explorer/modules/walk-score-iframe.php-nek nincs megfelelően ellenőrive, mielőtt visszaadásra kerülne. Ez kihasználható tetszőleges HTML és script kód futtatására a felhasználó böngészőjének munkamenetében, az érintett oldallal kapcsolatosan.

A sérülékenységet a 3.1.2 verzióban jelentették. Más verziók is érintettek lehetnek.

Megoldás

Javítsa a forráskódot a bemenet megfelelő ellenőrzése érdekében