WordPress Mail Subscribe List bővítmény sérülékenység

CH azonosító

CH-9397

Angol cím

WordPress Mail Subscribe List Plugin Script Insertion Vulnerability

Felfedezés dátuma

2013.06.11.

Súlyosság

Közepes

Érintett rendszerek

Mail Subscribe List Plugin
WordPress

Érintett verziók

WordPress Mail Subscribe List Plugin 2.x

Összefoglaló

A WordPress Mail Subscribe List bővítményének olyan sérülékenységét jelentették, amelyet kihasználva a támadók script beszúrásos (script insertion) támadásokat hajthatnak végre.

Leírás

Az “sml_name” POST paraméter által az index.php részére átadott bemeneti adatok nincsenek megfelelően megtisztítva, mielőtt felhasználásra kerülnének. Ezt kihasználva tetszőleges HTML és script kódot lehet futtatni a felhasználó böngészőjének munkamenetében az érintett oldal vonatkozásában, a kártékony adatok megtekintésekor.

A sérülékenységet a 2.0.9 verzióban jelentették, de korábbi kiadások is érintettek lehetnek.

Megoldás

Frissítsen a legújabb verzióra