WordPress Mailing List Plugin “wpabspath” fájl befoglalási sérülékenység

CH azonosító

CH-5579

Angol cím

WordPress Mailing List Plugin "wpabspath" File Inclusion Vulnerability

Felfedezés dátuma

2011.09.19.

Súlyosság

Magas

Érintett rendszerek

Mailing List plugin
WordPress

Érintett verziók

WordPress Mailing List Plugin 1.x

Összefoglaló

A WordPress Mailing List Plugin olyan sérülékenysége vált ismertté, a melyet kihasználva a támadók feltörhetik a sérülékeny rendszert.

Leírás

A “wpabspath” paraméteren keresztül a wp-content/plugins/mailz/lists/lt.php-nek vagy a wp-content/plugins/mailz/lists/index.php részére átadott bemeneti adat nincsen megfelelően ellenőrizve a wp-content/plugins/mailz/lists/config/config.php-ben fájlok befoglalása előtt. Ez kihasználható tetszőleges fájlok befoglalására helyi és kiterjesztett erőforrásokból.

A sérülékenységet a 1.3.3-as verzióban jelentették, továbbá megelőző verziók is érintettek lehetnek.

Megoldás

Frissítsen az 1.3.4-es verzióra.

Hivatkozások

SECUNIA 46040
Gyártói referencia: wordpress.org
Egyéb referencia: spareclockcycles.org