WordPress MailUp bővítmény sérülékenység

CH azonosító

CH-8704

Angol cím

WordPress MailUp Plugin Ajax Functions Security Bypass

Felfedezés dátuma

2013.03.12.

Súlyosság

Közepes

Érintett rendszerek

MailUp Plugin
WordPress

Érintett verziók

WordPress MailUp Plugin 1.x

Összefoglaló

A WordPress MailUp bővítmény olyan sérülékenysége vált ismertté, amelyet kihasználva a támadók megkerülhetnek bizonyos biztonsági szabályokat.

Leírás

A sérülékenységet az okozza, hogy az alkalmazás nem korlátozza megfelelően a hozzáférést egyes ajax függvényhívásokhoz a wp-content/plugins/wp-mailup/ajax.functions.php-ben (amikor pl. egy “wordpress_logged_in_test” cookie van beállítva), ami kihasználható a bővítmény beállítások módosítására, továbbá script beszúrásos (script insertion) támadások végrehajtására.

A sérülékenység az 1.3.2 verzióban található, egyéb kiadások is érintettek lehetnek.

Megoldás

Ismeretlen