WordPress MF Gig Calendar bővítmény cross-site scripting sérülékenység

CH azonosító

CH-7614

Angol cím

WordPress MF Gig Calendar Plugin URL Cross-Site Scripting Vulnerability

Felfedezés dátuma

2012.09.19.

Súlyosság

Alacsony

Érintett rendszerek

MF Gig Calendar Plugin
WordPress

Érintett verziók

WordPress MF Gig Calendar Plugin 0.x

Összefoglaló

A WordPress MF Gig Calendar bővítmény egy sérülékenységét jelentették, amit kihasználva a támadók cross-site scripting (XSS/CSS) támadásokat hajthatnak végre.

Leírás

Az URL-en keresztül átadott bemeneti adat (amikor a “page_id” Event Calendar page-re van állítva) nem megfelelően van megtisztítva, mielőtt a felhasználónak visszaadásra kerül. Ezt kihasználva, tetszőleges HTML és script kódot lehet futtatni a felhasználó böngészőjének munkamenetében az érintett oldal vonatkozásában.

A sérülékenységet a 0.9.4.1 verzióban jelentették, de más kiadások is érintettek lehetnek.

Megoldás

Ismeretlen