WordPress Mingle Forum plugin “message” script befecskendezéses sérülékenység

CH azonosító

CH-4477

Angol cím

WordPress Mingle Forum Plugin "message" Script Insertion Vulnerability

Felfedezés dátuma

2011.02.28.

Súlyosság

Alacsony

Érintett rendszerek

Mingle Forum plugin
WordPress

Érintett verziók

WordPress Mingle Forum Plugin 1.x

Összefoglaló

A WordPress-hez készített Mingle Forum plugin egy sérülékenységét jelentették, amelyet kihasználva a támadók script befecskendezéses (script injection) támadást indíthatnak.

Leírás

A wp-content/plugins/mingle-forum/wpf-insert.php fájlban lévő “message” POST paraméternek BBCode-on keresztül átadott bemeneti adatok (amikor az “add_topic_submit” tetszőleges értékre van állítva) nem megfelelően vannak megtisztítva, mielőtt a wp-content/plugins/mingle-forum/wpf.class.php keresztül más felhaszálóknál megjelenítésre kerülnek. Ez kihasználható tetszőleges HTML és script kód futtatására a felhasználó böngészőjének munkamenetében, az érintett oldallal kapcsolatosan.

A sérülékenységet az 1.0.29 verzióban jelentették. Más kiadások is érintve lehetnek.

Megoldás

Javítsa a forráskódot a bemenet megfelelő ellenőrzése érdekében