WordPress Multisite Plugin Manager bővítmény cross-site scripting sérülékenységek

CH azonosító

CH-7671

Angol cím

WordPress Multisite Plugin Manager Plugin Two Cross-Site Scripting Vulnerabilities

Felfedezés dátuma

2012.09.27.

Súlyosság

Alacsony

Érintett rendszerek

Multisite Plugin Manager
WordPress

Érintett verziók

WordPress Multisite Plugin Manager 3.x

Összefoglaló

A WordPress Multisite Plugin Manager bővítmény két sérülékenységét jelentették, amiket kihasználva a támadók cross-site scripting (XSS/CSS) támadásokat hajthatnak végre.

Leírás

A “mass_activate” és “mass_deactivate” paramétereken keresztül a wp-admin/network/plugins.php részére (amikor a “page” értéke “plugin-management”) átadott bemeneti adatok nem megfelelően vannak megtisztítva, mielőtt a felhasználónak visszaadásra kerülnének. Ezt kihasználva, tetszőleges HTML és script kódot lehet futtatni a felhasználó böngészőjének munkamenetében az érintett oldal vonatkozásában.

A sérülékenységeket a 3.1.1 verzióban jelentették, de korábbi kiadások is érintettek lehetnek.

Megoldás

Frissítsen a legújabb verzióra