WordPress PhotoSmash Plugin “action” cross-site scripting sérülékenység

CH azonosító

CH-5519

Angol cím

WordPress PhotoSmash Plugin "action" Cross-Site Scripting Vulnerability

Felfedezés dátuma

2011.09.08.

Súlyosság

Alacsony

Érintett rendszerek

PhotoSmash plugin
WordPress

Érintett verziók

WordPress PhotoSmash Plugin 1.x

Összefoglaló

A WordPress PhotoSmash Plugin olyan sérülékenysége vált ismertté, melyet kihasználva a támadók cross-site scripting (CSS/XSS) támadásokat tudnak végrehajtani.

Leírás

A “action” paraméteren keresztül a wp-content/plugins/photosmash-galleries/index.php-nek átadott bemeneti adat nincs megfelelően tisztázva a felhasználónak történő visszaadás előtt. Ez kihasználható tetszőleges HTML és script kód futtatására a felhasználó böngészőjének munkamenetében egy érintett oldallal kapcsolatosan.

A sérülékenység az 1.0.2-es és azt megelőző verziókban található.

Megoldás

Frissítsen az 1.0.5-ös verzióra.