WordPress post-views bővítmény cross-site scripting sérülékenység

CH azonosító

CH-7960

Angol cím

WordPress post-views Plugin "search_input" Cross-Site Scripting Vulnerability

Felfedezés dátuma

2012.11.15.

Súlyosság

Alacsony

Érintett rendszerek

WordPress
post-views Plugin

Érintett verziók

WordPress post-views Plugin 2.x

Összefoglaló

A WordPress post-views bővítményének olyan sérülékenységét jelentették, amelyet a támadók kihasználva cross-site scripting (XSS/CSS) támadásokat hajthatnak végre.

Leírás

A wp-admin/index.php részére “search_input” GET paraméterrel által átadott bemeneti adatok a (amikor a “page” értéke “post-views”) nincsenek megfelelően megtisztítva, mielőtt visszaadásra kerülnének. Ezt kihasználva, tetszőleges HTML és script kódot lehet futtatni a felhasználó böngészőjének munkamenetében az érintett oldal vonatkozásában.

A sérülékenységet a 2.6.1 verzióban jelentették, de más kiadások is érintettek lehetnek.

Megoldás

Ismeretlen